1. Thank you all for your patience with our technical errors. We think we've fixed it, but please do report anything that's not working right, by posting on the 'minor bugs' thread in Support and Feedback.
    Dismiss Notice
Tags:
  1. Wreybies

    Wreybies Thrice Retired Supporter Contributor

    Joined:
    May 1, 2008
    Messages:
    23,844
    Likes Received:
    20,803
    Location:
    El Tembloroso Caribe

    Security Error

    Discussion in 'Support & Feedback' started by Wreybies, May 16, 2020.

    It just happened, not a few minutes ago. 12:57 pm local time (UTC -4).

    It was there and gone before I could get a screen-cap, but it looked just all the other error messages the software gives. Black box highlighted with red. This is not the actual image, but another example I found online. Same message, though.

    Screen Shot 2020-05-16 at 12.59.35 PM.png
     
  2. Komposten

    Komposten Insanitary pile of rotten fruit Supporter Contributor

    Joined:
    Oct 18, 2012
    Messages:
    3,018
    Likes Received:
    2,188
    Location:
    Sweden
    The only error I can see in the server log at that time is an anonymiser error. But that happens like every 4 minutes, so I doubt that is related.

    Based on the message it sounds like maybe something weird happened to your credentials. You were logged in and sent a request to the server, something happened before the server received and suddenly it had invalid credentials appear in the middle of something. A refresh would cause the request to be sent again, with correct credentials.

    That's just a guess, though.
     
  3. NWOPD

    NWOPD Administrator

    Joined:
    Oct 16, 2020
    Messages:
    198
    Likes Received:
    256
    I know this is an old thread, but I wanted to comment for Wrey and members of the admin team so we can recognize and mitigate these types of errors in the future.

    This is most likely an error triggered server-side from mod_security, which I believe is an Apache function that blocks visitor actions that are potentially flagged as intrusive by our server software.

    Basically the server security system didn’t like something in your post. It could be a word, or more like a sequence of special characters. Basically the server thought you were trying to break in.

    We’ve encountered issues like this in the past that appeared with blog posts or private messages. We solved them by examining the exact content of the offending message and comparing them to the server log’s time stamps.

    If you or anyone encounters an error like this save your exact post content and the exact time. I can then look into it and adjust our server security settings to stop incorrectly flagging such content.

    Edit: looking at your screenshot it looks like something in the AdminCP. The cause is likely the same though, whatever action taken triggered mod_security.
     
    Komposten likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice